IT狗

android常犯错误记录(三)

Multiple dex files define Landroid/support/xxx

这个包冲突都是support里的,比如 Multiple dex files define Landroid/support/v4/app/FragmentTabHost$DummyTabFactory 或者 Multiple dex files define Landroid/support/design/widget/CoordinatorLayout;

不管什么原因,只要在gradle里面都引用一下覆盖版本就行了,不然有你哭的时候,出错日志如下

解决方案: 把后面的版本号都统一,重新运行,ok

 

Error:Execution failed for task ':app:transformDexArchiveWithExternalLibsDexMergerForDebug'.
> java.lang.RuntimeException: java.lang.RuntimeException: com.android.builder.dexing.DexArchiveMergerException: Unable to merge dex

百度了一番,发现没有让我失望,没什么用,因为原因可能不只一个,具体不好定位,后来我没办法就把所有的依赖版本升了一下,从27.0.0到28.0.0了,然后我一个个试了一遍,确定是谷歌的依赖库版本低了,估计你添加的依赖库里面的一些sdk和tools版本调成了28,

所以以前的低版本没法成功报错,如果你百度了很多办法都不行,不妨试试我这个,下面是我依赖过的库

 

此文由 IT狗 编辑,本网站所发布展示的作品/文章版权归原作者所有,任何商业用途均须联系作者!

相关推荐

评论 暂无评论